Can someone clarify how based on the below phones get an ip from mitel and computers from separate dhcp server and dont get the wrong ip when connected to the same port. I assume it is controlled by the switch and by virtue of the fact that vlan3 is tagged as voice and the mitel server is connected to a vlan3 only port?
extract:
ip subnet-zero
ip routing
!
!
mls qos
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
interface FastEthernet1/0/2
description Connection to Mitel 3300ICP
switchport access vlan 3
switchport mode access
priority-queue out
mls qos cos 5
mls qos trust cos
spanning-tree portfast
!
interface FastEthernet1/0/3
description Data and Mitel Voice
switchport access vlan 2
switchport mode access
switchport voice vlan 3
priority-queue out
mls qos trust cos
spanning-tree portfast
interface Vlan1
description Management VLAN
ip address x.x.x.1 255.255.255.0
!
interface Vlan2
description Data VLAN
ip address 111.22.333.1 255.255.255.0
ip helper-address 1.2.3.4
ip helper-address 5.6.7.8
!
interface Vlan3
description Mitel Voice VLAN
ip address 192.168.1.1 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 100.0.0.100
ip http server
!
Mitel:
Confusing me is that in system ip on the mitel voice is vlan1
Layer 2 switch voice vlan 1
DHCP subnet name voice vlan 192.168.1.0
DHCP Range specifies voice vlan 192.168.1.0
DHCP options 125 does not specify a vlan, that field is blank, it only includes tftp and call server.
Many thanks