Home Page Articles User Guides News Letter  



Author Topic: Micollab server disable chat history  (Read 129 times)

Offline ITMgr5

  • New Member
  • *
  • Posts: 4
  • Country: us
  • Karma: +0/-0
    • View Profile
Micollab server disable chat history
« on: January 11, 2018, 05:35:16 PM »
All:
I've seen this question asked for earlier versions of Micollab, but nothing recent.  Is it possible to disable chat history from the Micollab server?  I see it can be disabled by the end user in the Micollab client, but this is difficult to enforce. For legal reasons we need to be sure that chat history is not being logged (but we want to keep the chat feature).

We are using Micollab server version 8.0.0.301.

Thanks for any advice!


Offline johnp

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1206
  • Country: us
  • Karma: +13/-0
    • View Profile
Re: Micollab server disable chat history
« Reply #1 on: January 11, 2018, 06:37:59 PM »
I'm pretty sure that this can still be done

Offline ITMgr5

  • New Member
  • *
  • Posts: 4
  • Country: us
  • Karma: +0/-0
    • View Profile
Re: Micollab server disable chat history
« Reply #2 on: January 12, 2018, 11:35:59 AM »
I found these instructions online but Iím not experienced using the command line interface (I have used various Linux incarnations). Anyone know if this is still the method to use?  Our consultants say no but I'm finding it hard to believe that chat history can't be disabled.  Most firms I've worked in (finance industry) would want this.

http://mitelforums.com/forum/index.php?topic=6525.0

To prevent UCA from storing chat history on the server, there two commands.

(1) edit /etc/e-smith/templates/opt/intertel/conf/sip_ims.ini/50Configuration set EnableFile=no. (if you're familiar with linux you can use vi editor to do this as well, I had to do this as my version of linux didn't recognise the "edit" command)

(2) expand-template /opt/intertel/conf/sip_ims.ini

Next, to delete the existing chat history stored on the server:
(1) stop the SIPIMS service from the UCA diagnostic page. From Server Manager, go to the main UCA configuration page, then at the bottom of the page under "Diagnostics", press the "Perform Server Diagnostics" button. Look for "SIPIMS" and click the "Stop" link to the right.

(2) move all files from the /opt/intertel/data/imarchive directory, maybe move them to /root by doing a 'mv hab_ims_archive* /root' from the /opt/intertel/data/imarchive directory. You can do this with putty, but if there are lots of files, you may want to use an application like WinSCP so that you can create folders, and drag and drop multiple files at once. Or, you can delete them from the putty command line if you are comfortable doing so - and will not want to keep the history at all.

(3) restart the UCA server completely.

Offline ITMgr5

  • New Member
  • *
  • Posts: 4
  • Country: us
  • Karma: +0/-0
    • View Profile
Re: Micollab server disable chat history
« Reply #3 on: January 17, 2018, 01:33:19 PM »
So, used the instructions above and they seem to still be valid on micollab server 8.0.0.301 for deleting chat history from the server. However it does not affect the client - users still have the option to save chat history indefinitely.

I might be able to write a script file that clears the chat folder on login, but this might be unreliable especially for remote users.

Any info on how the client chat history can be disabled?



Offline johnp

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1206
  • Country: us
  • Karma: +13/-0
    • View Profile
Re: Micollab server disable chat history
« Reply #4 on: January 18, 2018, 06:28:07 PM »
Think Mitel would need to be asked if there is a method.


 

Sitemap 1 2 3 4 5 6 7 8 9