Home Page Articles User Guides News Letter  



Author Topic: Set DDI to Give Busy Tone  (Read 152 times)

Offline ImaCircularSaw

  • New Member
  • *
  • Posts: 4
  • Country: gb
  • Karma: +0/-0
    • View Profile
Set DDI to Give Busy Tone
« on: January 05, 2018, 11:30:07 AM »
Hi All,

Brand new to this forum and I've been trying to solve a configuration issue I'm having.  Apologies if I get terminology wrong or miss something obvious - system here is only approx. a year old and I'm not the usual admin.

System is Mitel Voice Business setup at the following version levels:

  - Release level: 8.0 
  - Active software load: 14.0.0.90

Scenario
We are using a solution called  NatterBox (https://www.natterbox.com/) to receive calls and forward them to one of our Mitel DDI's.  NatterBox is configured to make certain Salesforce lookups and forward the call to a certain DDI based on these lookups.  My understanding is that NatterBox calls the chosen DDI and when someone answers, it connects both legs of the call together.

Now, we would like Mitel to respond in the following ways:

  • If callee is logged in and not already on a call, the response should be a ring.
  • If callee is logged out, the response should be a busy tone.
  • If callee is already on a call, the response should be a busy tone.

Currently, under scenarios 2 & 3, we get ringing instead of busy tones.  We have removed voicemail from the DDIs as well.

So to summarise, I'm asking, is there a way to configure these to give busy tone instead of ringing when line is in use or logged out?

Thanks in advance!
« Last Edit: January 05, 2018, 11:36:13 AM by ImaCircularSaw »


Offline VinceWhirlwind

  • Hero Member
  • *****
  • Posts: 519
  • Country: au
  • Karma: +13/-0
    • View Profile
Re: Set DDI to Give Busy Tone
« Reply #1 on: January 07, 2018, 08:50:15 PM »
Test one of the target extensions: when you set it to DND (or just put it off-hook) and then call it, does it ring? If so, where is it ringing?
 
Possible reasons for it to be ringing when the device is busy would be Call Re-routing, Call Forward Busy, or having multiple line keys on it.
Respectively for each case, remove the Call Re-routing, remove the Call Forward, change the phone/user CoS setting "device busy if any line in use"=True.

Offline ImaCircularSaw

  • New Member
  • *
  • Posts: 4
  • Country: gb
  • Karma: +0/-0
    • View Profile
Re: Set DDI to Give Busy Tone
« Reply #2 on: January 08, 2018, 07:04:11 AM »
Thanks for your reply!

So I've carried out the following testing:

When user is logged in:
  • Called user, answered call and left the call live.
  • Called user from second number, call kept ringing.
  • Called user from third number, call kept ringing.

When user is logged off:
  • Called user, number kept ringing.
  • Called user from second number, call kept ringing.
  • Called user from third number, call kept ringing.

I also did as you suggested, and set my EXT to DND and it rang through to voicemail.  However, the actual EXT I want to alter is in use today soI'll need to schedule some time this evening to test it so will do that and report back.

Your suggestion of changing the user CoS setting sounds interesting.  However, I am not sure where I'm looking for that option.  Are you able to give a bit more detail on how I ace is? 

Thank you!

Offline ralph

  • Mitel Forums Admin
  • Hero Member
  • *****
  • Posts: 5289
  • Country: us
  • Karma: +453/-0
  • Published Author: http://amzn.to/2dcYSY5
    • View Profile
Re: Set DDI to Give Busy Tone
« Reply #3 on: January 08, 2018, 08:53:25 AM »
The reason you're getting ringing when the phone is busy is because it's doing an Auto Campon.

In the COS of the phone, blank out the "Auto Campon Timer" and then try it.

Ralph

Offline ImaCircularSaw

  • New Member
  • *
  • Posts: 4
  • Country: gb
  • Karma: +0/-0
    • View Profile
Re: Set DDI to Give Busy Tone
« Reply #4 on: January 11, 2018, 05:30:31 AM »
Hi both,

Thanks for your replies and ideas. 

Ralph, as advised, we removed the CAMPON timer from the SIP Trunk CoS (64) and it's worked for when the user is logged in.  However, when user is not logged in we get two results depending on where you call from:

  • Internal callers recieve 'Not Allowed' on the phone display and get a 'dead' tone (not sure the right terminology).
  • External caller get silence which does not time out.  I think this is a lack of a RBT (Ring Back Tone)?

So we're half way there.  Is there anything else you can thing or or any more info I might not have provided?

Cheers!
« Last Edit: January 11, 2018, 06:50:35 AM by ImaCircularSaw »

Offline ralph

  • Mitel Forums Admin
  • Hero Member
  • *****
  • Posts: 5289
  • Country: us
  • Karma: +453/-0
  • Published Author: http://amzn.to/2dcYSY5
    • View Profile
Re: Set DDI to Give Busy Tone
« Reply #5 on: January 11, 2018, 07:29:07 AM »
What happens if you put the phone in Do Not Disturb rather than logging out?

Ralph

Offline johnp

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1203
  • Country: us
  • Karma: +13/-0
    • View Profile
Re: Set DDI to Give Busy Tone
« Reply #6 on: January 11, 2018, 06:32:01 PM »
Just a thought, you might be able to intercept the logged off user to recorded busy tone

Offline ImaCircularSaw

  • New Member
  • *
  • Posts: 4
  • Country: gb
  • Karma: +0/-0
    • View Profile
Re: Set DDI to Give Busy Tone
« Reply #7 on: Today at 09:39:43 AM »
Hi Both,

Sorry it's taken a while to get back.

Ralph, currently when a user is set to DND the number still rings when called.  I've tried setting DND through the phone and through Users and Devices > Advanced configuration >DND.

when the phone is engaged or off the hook, and someone calls you get a busy tone (what we're after!).  When user is logged in but available the phone rings as it should.

Does that help at all?

johnp, are you suggesting that we redirect someone to a pre-recorded message which is the busy tone?  Are you able to add some more detail to your suggestion please?  I've had a look at the settings under Call Routing > Call Handling > Intercept Handling, but have not been able to work out what it is you're suggesting.

Cheers Both!


 

Sitemap 1 2 3 4 5 6 7 8 9