Home Page Articles User Guides News Letter  



Author Topic: No audio on transferred call  (Read 226 times)

Offline dhumes0524

  • Contributer
  • *
  • Posts: 22
  • Country: us
  • Karma: +0/-0
    • View Profile
No audio on transferred call
« on: December 19, 2017, 01:34:06 PM »
Hi, we have a MiVoice Office 250 v6.2.  We have two trunk groups (one PRI and one SIP).  If a call comes in on my SIP trunk, and we then transfer that call back out to an external mobile number - the call still places but no audio can be heard in either direction, including the ringing. 

If a call comes into our PRI, and we transfer that out to an external number, it works fine and everyone can hear each other.

Can someone point me in the direction of what to look at for this?  Thank you so much!


Online Tech Electronics

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1926
  • Country: us
  • Karma: +48/-0
    • View Profile
Re: No audio on transferred call
« Reply #1 on: December 19, 2017, 02:23:01 PM »
dhumes0524,

Well, that is a loaded gun. It sounds as though your SIP Trunks weren't configured correctly to begin with.

1. If you have a call come into your SIP trunks and you Transfer/Forward it back out either SIP or PRI does it work?
2. If you have a call come into your SIP trunks and you put it on Hold and pick it back up does it work?
3. If you have a call come into your SIP trunk and you create a conference call with either SIP or PRI does it work?

Just so you know you may need to get your vendor back out to finish setting your system up properly.

Thanks,

TE

Offline dhumes0524

  • Contributer
  • *
  • Posts: 22
  • Country: us
  • Karma: +0/-0
    • View Profile
Re: No audio on transferred call
« Reply #2 on: December 19, 2017, 02:31:29 PM »
I expected to maybe have to include the vendor and have an email out to them to check into the SIP configuration.

1. How to I control which trunk it goes back out on?
2. Yes this works correctly.
3. Do you mean if I call into the SIP trunk, and then conference in a third party to that call, does it work?  I am unclear on how to select which trunk I would be dialing out to the third party on.

Online Tech Electronics

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1926
  • Country: us
  • Karma: +48/-0
    • View Profile
Re: No audio on transferred call
« Reply #3 on: December 19, 2017, 03:11:36 PM »
dhumes0524,

Alright. So to pick a type of trunk you would need to know the Trunk Group number associated with it. You would also have to have a phone set to not use ARS Only or setup each trunk group to be Exempt From ARS Only so you can dial it.

Go to System > Devices and Feature Codes > CO Trunk Groups: Hopefully you only have one here and it is most likely 92001. If you go a little further you can get into Toll Restriction and select Exempt From ARS Only.

The other spot you need to look at is System > Devices and Feature Codes > SIP Peers > SIP Trunk Group > 92002 [possibly] > Trunk Group Configuration > Toll Restriction > Exempt From ARS Only.

When you want to use a particular type of trunk you dial the trunk group directly instead of dialing 8 or 9 for an outside line.

Thanks,

TE

Offline dhumes0524

  • Contributer
  • *
  • Posts: 22
  • Country: us
  • Karma: +0/-0
    • View Profile
Re: No audio on transferred call
« Reply #4 on: December 19, 2017, 03:42:12 PM »
I am somewhat green to the system, but it looks like we are not currently using ARS - our Outgoing extensions on our phones are set to 92001 instead of 92000, and for the phones that need to use the SIP trunk group, they are using 92003.

If I am trying to send the transferred SIP call out my PRI (setting outgoing extension on receptionist to 92001) - it doesn't work and that is when no audio heard on either side.

If I send the SIP call back out the same SIP trunk group ((setting outgoing extension on receptionist to 92003) - works and we can hear each other.

My receptionist answers incoming calls on both the SIP trunk group and the PRI trunk group.

I am hoping that my vendor can modify the SIP in a way that it will allow me to transfer the call from the SIP trunk over to our PRI trunk.

Offline dhumes0524

  • Contributer
  • *
  • Posts: 22
  • Country: us
  • Karma: +0/-0
    • View Profile
Re: No audio on transferred call
« Reply #5 on: December 21, 2017, 09:50:14 AM »
Just did some testing with their vendor and they indicated that after the transfer occurs they "are not seeing the signaling for the redirect of the media".  They are asking for additional debugging on the Mitel system, which I dont personally know how to do, but can pull in my vendor if necessary.  Are there any kind of settings on my PRI or SIP trunks that I should look at in regards to being able to transfer calls between the two trunks ?

Online Tech Electronics

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1926
  • Country: us
  • Karma: +48/-0
    • View Profile
Re: No audio on transferred call
« Reply #6 on: December 21, 2017, 10:16:50 AM »
dhumes0524,

So they see the redirect when going back out SIP, but they don't see it when it goes out the PRI?

As far as I know there isn't anything for redirects in the SIP Peer Profile.

I would need to see some packet captures from a good transfer and one from a bad transfer in order to figure that one out. Most likely you will need to bring in your vendor as integration issues can take some time to sort out.

Sorry,

TE

Offline dhumes0524

  • Contributer
  • *
  • Posts: 22
  • Country: us
  • Karma: +0/-0
    • View Profile
Re: No audio on transferred call
« Reply #7 on: Today at 11:01:28 AM »
Hi, I am following up with what Mitel found to make this work.  In the SIP trunk and PRI trunk groups we needed to enable "Echo Trunk Number" and now the calls have audio.


 

Sitemap 1 2 3 4 5 6 7 8 9