Author Topic: CISCO Routing 3750 to subnets  (Read 2789 times)

RogerV

  • Guest
CISCO Routing 3750 to subnets
« on: April 23, 2015, 04:08:17 PM »
I have a Lan 172.20.0.0 on vlan 1 and 10.200.0.0 on vlan 80.
I have a cisco 3750 with vlan 80 programmed with 10.200.0.1 and the 3750 can see the both its self and vlan 1 but vlan 1 can not see vlan 80.

what route do i need in the 3750 for vlan 1 to ping a device on vlan 80.


Please HELp???!!!!


Offline martyn

  • Hero Member
  • *****
  • Posts: 688
  • Country: au
  • Karma: +10/-0
    • View Profile
Re: CISCO Routing 3750 to subnets
« Reply #1 on: April 23, 2015, 07:06:14 PM »
There are a few things here. Do you have ip routing enabled on the 3750? Also is the default gateway on the PC set to the vlan 1 address of the 3750? Also does the 3750 have an ip address on both vlans?
Post your config here if you want.

RogerV

  • Guest
Re: CISCO Routing 3750 to subnets
« Reply #2 on: April 23, 2015, 07:11:31 PM »

Switch>
Switch>
Switch>
Switch>en
Switch#show run
Building configuration...

Current configuration : 4884 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
no aaa new-model
switch 1 provision ws-c3750-24p
system mtu routing 1500
ip subnet-zero
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/6
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/7
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/8
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/9
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/10
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/11
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/12
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/13
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/14
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/15
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/16
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/17
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/18
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/19
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/20
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/21
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/22
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80
 switchport mode trunk
 switchport voice vlan 80
 spanning-tree portfast
!
interface FastEthernet1/0/24
 switchport access vlan 80
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface Vlan1
 ip address 172.20.0.3 255.255.255.0
!
interface Vlan80
 ip address 10.200.0.1 255.255.255.0
!
ip classless
ip route 10.200.0.0 255.255.255.0 172.20.0.0
ip http server
!
!
control-plane
!
!
line con 0
line vty 0 4
 login
line vty 5 15
 login
!
end

Switch#

Offline martyn

  • Hero Member
  • *****
  • Posts: 688
  • Country: au
  • Karma: +10/-0
    • View Profile
Re: CISCO Routing 3750 to subnets
« Reply #3 on: April 23, 2015, 07:14:45 PM »
Yep, so you need the following:

Quote
en
conf t
ip routing

Is the 3750 the default gateway for the PC's?
Also, with your switch ports you shouldn't need them in trunk mode, access is only required, but that's separate from this issue.

Offline johnp

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2183
  • Country: us
  • Karma: +66/-0
    • View Profile
Re: CISCO Routing 3750 to subnets
« Reply #4 on: April 23, 2015, 07:25:28 PM »
I would assume that the default gateway for vlan 1 isn't this device. Also this could be removed ip route 10.200.0.0 255.255.255.0 172.20.0.0 the switch know both already and it doesn't look valid anyway.

I would think a route needs to be added to the vlan 1 gateway such that 10.200.0.0 255.255.255.0 routes via 172.20.0.3

RogerV

  • Guest
Re: CISCO Routing 3750 to subnets
« Reply #5 on: May 21, 2015, 03:43:10 PM »
Thnaks adding that route help!!


 

Sitemap 1 2 3 4 5 6 7 8 9 10